A ribbon cable connection issue is a rare problem that can occur if someone or something knocks the ribbon cable (the flat striped cable connecting the motor to the electronics pod) out of position.
Symptoms:
- One of the cables has been pulled out.
- One of the calipers never moves.*
- One of the calipers can move slightly, but doesn’t respond to all commands.*
- Only one caliper repeatedly rubs on the wheel.*
- The centering tool in STAC Control Panel's tutorial gives you nonsensical feedback (for example, the app tells you to move further the drive side, when the wheel already looks way too far to the drive side).
*Alternative issues:
A bike that is not centred in the trainer (with the wheel over the center bolt), or a Halcyon Upgrade Kit that is not properly aligned can result in a caliper that cannot achieve its intended range of motion. This is the more common cause of these symptoms:
- One of the calipers can move slightly.
- Only one caliper repeatedly rubs on the wheel.
Diagnosis:
If you haven't already done so, check that the wheel is centered over the center bolt.
Next, to confirm you have a ribbon cable problem:
- Connect to the trainer in STAC Control Panel.
- Go to the MANUAL POSITIONING screen. At the bottom, there should be two sliders that represent the detected position of each motor.
- Press FIND WHEEL, OPEN ALL THE WAY and GO TO WHEEL RIM. If the slider corresponding with the Caliper you are troubleshooting does not move, barely moves, or doesn’t correspond with the movement of the Caliper, you have a Ribbon Cable connection problem.
Solutions:
If the drive side caliper isn't moving well, giving the cable a little jiggle may be enough.
Alternatively, you may still be able to reinsert the drive side cable without removing the electronics cover. The trick is to insert it just far enough that you can see the barest edge of the the gold contact.
If the non-drive side caliper that isn't working, below is an instructional videos for repairing it yourself:
https://www.youtube.com/watch?v=rsKA7x-1jpI&feature=youtu.be
This video for a battery replacement demonstrates how to remove the guard plate, and shows both types of cable contact points you could potentially encounter:
https://www.youtube.com/watch?v=Yy0yoX-Z7RY&feature=youtu.be
Steps to reinsert the cable:
- Remove the Resistance Unit from the Frame.
- Remove the two small screws on the bottom lid of the electronics case. This will most likely require a Phillips screwdriver. Depending on when your unit was built may require a Torx 7.
- Remove the lid. There are small snaps and some glue holding it on, but it should come free with some wiggling.
- Reinsert the cable in the connection port. Insert it just far enough that the gold contact is covered, no further. Alternatively, insert it until it bottoms out, and then pull it out slightly, just until the slightest edge of gold contact becomes visible.
- Optional: if you own a hot glue gun, add a small dab of glue to the contacts.
- Remove any residual glue from the lid using a small pair of pliers. Replace the lid. Replace the screws.
If you have remove the resistance unit to get at the case, refer the back of your manual for instructions on how to realign it when you mount it on the frame, or see alignment instruction here.